Tuesday, January 13, 2009

Connecting Cisco Switches to Avaya/Polycom/HP and Etc Phones

Only Cisco & Mitel phones will use CDP to discover the Voice VLAN, however other methods exist to inform the IP Phones of the voice VLAN. Ericsson/Aastra, Nortel & Avaya all use DHCP they boot on the access VLAN and via DHCP options discover the Voice VLAN, they then release the IP address and restart using 802.1q tagged frames.
Although the functionality of an Access port configured like this:

CODE

switchport mode access
switchport access vlan 10
switchport voice vlan 100
is the same as a trunk configured like this

CODE

switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100


There are other implations of hard-coding the port as a trunk which is why I wouldn't recommend it.
I have sucessfully deployed several Nortel, Ericsson & Mitel IP Telephony systems using access ports with voice vlans.

Back to the original problem though... Are you plugging the phones directly into the switch using a fully-wired patch cable (i.e. not via the infrastructure cabling)? Are you trying to hard-code speed & duplex (don't....). Have you done any debugging?




I've always understood from Cisco that non-cisco devices should have a proper .1q trunk configured.

For example:
http://www.cisco.com/en/US/products/hw/switches/ps708/products_configuration_example09186a0080891554.shtml

It doesn't make a huge difference, I suppose, because you end up with something similar in either case.

Like you, I have deployed Nortel, Ericsson and Siemens IP phones using my particular bias when it comes to switch configuration. :)

Not that I've often had power issues. Once I found a switch that was refusing to grant power due to being "out of memory", which was somehow caused by a damaged stackport.

LLDP - now theres a thing. Yes this should work but its only supported on the newer Catalysts (2960, 3560, 3750) and 6500's. For some reason (to sell more product...) Cisco have refused to add LLDP to the older switches. I know Nortel support LLDP as well as the newer Cisco IP Phones. Ericsson/Aastra certainly don't in the latest firmware but its supposed to be coming? Not sure about Mitel or Avaya?


I have some Polycom phones going to an Adtran T1 L3 switch (PoE, basically a Cisco!) that they say can use CDP. The phones are SPIP-500/501


I recall HP switches used CDP until firmware updates in 2005/2006.

Don't forget Cisco supports LLDP, though, if your phones support it.

Avaya does support LLDP. Avaya phones also work with either switchport voice vlan OR 802.1Q trunk ports using DHCP/Text files to configure VLAN assignment.

I have heard, If we add one by one Avaya or Nortel IP Phones to cisco switches (mostly 48 port), SOME TIMES last couple of phone finds not enough power to bootup. This usually happens when all the 48 ports are used.

Courtesy
http://www.tek-tips.com/viewthread.cfm?qid=1517008&page=1

Monday, January 12, 2009

Upgrading from 4.X to CUCM 6.0

I found this brief detail from a forum regarding The upgrade process, latter i will more details. courtesy cukon.


Yes it is possible to upgrade directly from CCM 4.2 to CCM 6.You need to download DMA (data migration assistant) tool from cisco, then you start to run this tool on CCM 4.2 publisher and output of this tool is file with CCM configuration, then you can install CCM 6.x, installation process ask you if you want to make fresh installation or you migrate from old CCM 4.x, you choose second option and installation process will ask you for file from DMA tool (file must be stored on some network directory). After CCM 6 published is installed you must add subscriber on the new CCM web admin and then you can install it...thats all :-)

About licences: licenses are migrated automatically based on number of endpoints in CCM 4 (you can add some virtual phones in CCM 4 before use DMA tool if you want to have more DLU licences in CCM 6 :-) ) to the new CCM6.At the end you must download these "migrated licences" from CCM6 and use it with ordered upgrade PAK from cisco on cisco WEB.Output of this will be true CCM6 licences which you must upload back to CCM6.

Thats all :-) Good for you will be upgrade guide which you can download from cisco pages.

Friday, January 9, 2009

WildCards in CCM 4.1 Demystified

I had Some problems understanding couple of wild cards the following examples have clarified my concepts in detail.

Numbers to Match---------------------------Route Pattern
2200–2299-------------------------------------22XX
2200–2499-----------------------------------2[2–4]XX
2200–2299 and 2400–2699------------2[24–6]XX

1231[^0-2]6[981]+

The above example illustrates only single entry resides in [], so except the range between 0-2 any single digit number can be matched with this entry. [981] means only 9 8 or 1 can occupy this region.

After all the digits are dialed, if the CCM has more than one route pattern that matches all the digits, the CCM uses the most specific route pattern. For example, consider the following scenario:
Dialed number: 555-1234

CCM route pattern matches: 555-12XX, 555-12[2–4]X

In this example, the CCM uses the 555-12[2–4]X route pattern, because 100 potential matches exist for the 555-12XX route pattern whereas only 30 potential matches exist for the 555-12[2–4]X route pattern. Therefore, the 555-12[2–4]X route pattern is deemed to be
more specific.

Monday, January 5, 2009

How to Configure EtherSwitch Modules in 2851-2821 and Changing the 3750 IOS on the EtherSwitch.

In this guide i am going to focus on how to add EtherSwitch modules in cisco 2851 and 2821 and changing the IOS on the EtherSwitch. cisco 2851 can reside a 48 port EtherSwitch module. i am going to describe this step by step.

http://www.cisco.com/en/US/prod/collateral/routers/ps259/product_data_sheet09186a00801aca3e.html

1 - Remove the Steel clamping on the back to insert the module.

2 - Now insert the module and push it gently until you are satisfied the module is completely inside, this step can be a little daunting because initially it took quite a while to set up the module correctly in the slot, The module wont come up if it isn't inserted correctly, it took a number of insertions and removals until the module finally came up so keep trying if you are having difficulties in inserting the module, in the latter releases it took much less time to set up the module. cisco 24 port Etherswitch module took less time to set up i guess beacuse of the special handle provided with the module.

3 - Next step is to access the module.

4 - Go to routers CLI and give an IP address to the GigabitEthernet 1/0 interface (may be diffrernt in your case), if you type #sh ip interface brief you can clearly see one gig interface is seperatly mentioned right at the bottom of the output that is your gig interface i.e your backplane connectivity to the router. assign an IP address to the interface and a #no shut. the backplane interface is UP.

5 - now type #Service-module GigabitEthernet 1/0 session , to access the module once you have accessed you can update the Image on the Switch.

6 - To Update the IOS on the switch start the TFTPD on the PC connected to FastEthernet interface. on the EtherSwitch Module issue the following commands.

7 - make this interface routed port assign an IP address to this interface.

8 - start the TFTPD on the PC.

9 - issue the following commands on the switch CLI.

10 - #copy tftp flash: , give the required IP address and the name of the IOS file the output will show exclamation marks and the copying will start.

11 - #boot system flash:IOS-name.bin to set the new IOS.

12 - #wr er this will not erase the boot system flash command.

13 - To go back to the router CLI press ctrl+shift+6 and then press "x".

14 - #disconnect ,to terminate the session with the router CLI.