Thursday, January 21, 2010
DHCP config with MS loopback adapter
Here is the attached snapshot and config of my dhcp on 3725 router to get the desired result. Yes I m excited!
ip dhcp pool DATA
network 172.16.2.0 255.255.255.0
default-router 172.16.2.1
dns-server 4.2.2.2
!
!
!
interface FastEthernet0/0
ip address 172.16.2.1 255.255.255.0
duplex auto
Wednesday, January 20, 2010
Configuring Inter VLAN routing and DHCP-Scope-VLAN Bindings
Hats off to Taha for digging it to the level it demanded, this exercise has polished DHCP and inter vlan routing issues. the details of the config are as follows
Replace the 3550 with 3725 hooked with NM-16-ESW, yep im speaking the GNS-3 language, the IP addressing is different from the above image but topology remains the same, the configs are follows.
Layer3_Switch Config
!---ENABLING IP ROUTING
conft# ip routing
!---INTERFACE TO DHCP ROUTER
conft# interface fa1/1
conft# no switchport
conft# ip address 200.1.1.1 255.255.255.0
conft# no shutdown
!---CREATING DATA AND VOICE VLANS
conft# vlan 10
conft# name VOICE
conft# vlan 10
conft# name DATA
!---CREATING SVIs FOR DATA AND VOICE VLANS
conft# interface vlan 10
conft# ip address 172.16.1.1 255.255.255.0
ADDING AN IP HELPER ADDRESS TO DHCP SERVER TO GET AN IP THROUGH VOICE SCOPE
conft# ip helper-address 200.1.1.2
conft# no shutdown
conft# interface vlan 20
conft# ip address 172.16.2.1 255.255.255.0
ADDING AN IP HELPER ADDRESS TO DHCP SERVER TO GET AN IP THROUGH DATA SCOPE
conft# ip-helper address 200.1.1.2
conft# no shutdown
!---INTERFACE TO PC AND IP SOFT/PHONE
conft# interface fa1/10
conft# switchport access vlan 20
conft# switchport voice vlan 10
conft# no shutdown
!---CREATING A DEFAULT ROUTE
------------------------------------------------------------
DHCP Router Config
conft# interface fa0/0
conft# ip address 200.1.1.2 255.255.255.0
conft# no shutdown
(config)# ip dhcp excluded-address 172.16.1.1 172.16.1.9
(config)# ip dhcp excluded-address 172.16.2.1 172.16.2.9
(config)# ip dhcp pool DATA
(dhcp-config)# network 172.16.2.0 255.255.255.0
(dhcp-config)# default-router 172.16.2.1
(dhcp-config)# dns-server 4.2.2.2
(dhcp-config)# exit
(config)# ip dhcp pool VOICE
(dhcp-config)# network 172.16.1.0 255.255.255.0
(dhcp-config)# default-router 172.16.1.1
(dhcp-config)# option 150 ip 172.16.1.1
(dhcp-config)# exit
(config)# ip route 172.16.1.0 255.255.255.0 200.1.1.1
(config)# ip route 172.16.2.0 255.255.255.0 200.1.1.1
very helpful reference document,
http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a008019e74e.shtml
Replace the 3550 with 3725 hooked with NM-16-ESW, yep im speaking the GNS-3 language, the IP addressing is different from the above image but topology remains the same, the configs are follows.
Layer3_Switch Config
!---ENABLING IP ROUTING
conft# ip routing
!---INTERFACE TO DHCP ROUTER
conft# interface fa1/1
conft# no switchport
conft# ip address 200.1.1.1 255.255.255.0
conft# no shutdown
!---CREATING DATA AND VOICE VLANS
conft# vlan 10
conft# name VOICE
conft# vlan 10
conft# name DATA
!---CREATING SVIs FOR DATA AND VOICE VLANS
conft# interface vlan 10
conft# ip address 172.16.1.1 255.255.255.0
ADDING AN IP HELPER ADDRESS TO DHCP SERVER TO GET AN IP THROUGH VOICE SCOPE
conft# ip helper-address 200.1.1.2
conft# no shutdown
conft# interface vlan 20
conft# ip address 172.16.2.1 255.255.255.0
ADDING AN IP HELPER ADDRESS TO DHCP SERVER TO GET AN IP THROUGH DATA SCOPE
conft# ip-helper address 200.1.1.2
conft# no shutdown
!---INTERFACE TO PC AND IP SOFT/PHONE
conft# interface fa1/10
conft# switchport access vlan 20
conft# switchport voice vlan 10
conft# no shutdown
!---CREATING A DEFAULT ROUTE
------------------------------------------------------------
DHCP Router Config
conft# interface fa0/0
conft# ip address 200.1.1.2 255.255.255.0
conft# no shutdown
(config)# ip dhcp excluded-address 172.16.1.1 172.16.1.9
(config)# ip dhcp excluded-address 172.16.2.1 172.16.2.9
(config)# ip dhcp pool DATA
(dhcp-config)# network 172.16.2.0 255.255.255.0
(dhcp-config)# default-router 172.16.2.1
(dhcp-config)# dns-server 4.2.2.2
(dhcp-config)# exit
(config)# ip dhcp pool VOICE
(dhcp-config)# network 172.16.1.0 255.255.255.0
(dhcp-config)# default-router 172.16.1.1
(dhcp-config)# option 150 ip 172.16.1.1
(dhcp-config)# exit
(config)# ip route 172.16.1.0 255.255.255.0 200.1.1.1
(config)# ip route 172.16.2.0 255.255.255.0 200.1.1.1
very helpful reference document,
http://www.cisco.com/en/US/tech/tk389/tk815/technologies_configuration_example09186a008019e74e.shtml
Sunday, January 17, 2010
Voice Lab Setup 17-1-09
I have started setting up my home voice lab with initial infrastructure using 3725 routers at HQ, BR1 and BR2. I have added wic-2T and nm-16esw cards in each router. The initial step include the frame-relay setup among above 3 routers using frame relay switch. We can ping each HQ > BR1 and vice versa and also From HQ > BR2 and vice versa.
The config snap and topology snap is attached for your review.
Next steps would be adding HQ to local LAN, configuring vlans, dhcp server and ospf.
The config snap and topology snap is attached for your review.
Next steps would be adding HQ to local LAN, configuring vlans, dhcp server and ospf.
Tuesday, January 12, 2010
MCSE log
Classes of IP addresses,
Class A : 1-126 : 1.0.0.1 to 126.255.255.254
Class B : 128-191 : 128.1.0.1 to 191.255.255.254
Class C : 192-223 : 192.0.1.1 to 223.255.254.254
Class D : 224-239 : 224.0.0.0 to 239.255.255.255
Class E : 240-254 : 240.0.0.0 to 254.255.255.254
Class A : 1-126 : 1.0.0.1 to 126.255.255.254
Class B : 128-191 : 128.1.0.1 to 191.255.255.254
Class C : 192-223 : 192.0.1.1 to 223.255.254.254
Class D : 224-239 : 224.0.0.0 to 239.255.255.255
Class E : 240-254 : 240.0.0.0 to 254.255.255.254
pecial address ranges
Some addresses are reserved for special uses (RFC 3330).[2]
Address range | CIDR Equivalent | Purpose | RFC | Class | Total # of addresses |
---|---|---|---|---|---|
0.0.0.0 - 0.255.255.255 | 0.0.0.0/8 | Zero Addresses | RFC 1700 | A | 16,777,216 |
10.0.0.0 - 10.255.255.255 | 10.0.0.0/8 | Private IP addresses | RFC 1918 | A | 16,777,216 |
127.0.0.0 - 127.255.255.255 | 127.0.0.0/8 | Localhost Loopback Address | RFC 1700 | A | 16,777,216 |
169.254.0.0 - 169.254.255.255 | 169.254.0.0/16 | Zeroconf / APIPA | RFC 3330 | B | 65,536 |
172.16.0.0 - 172.31.255.255 | 172.16.0.0/12 | Private IP addresses | RFC 1918 | B | 1,048,576 |
192.0.2.0 - 192.0.2.255 | 192.0.2.0/24 | Documentation and Examples | RFC 3330 | C | 256 |
192.88.99.0 - 192.88.99.255 | 192.88.99.0/24 | IPv6 to IPv4 relay Anycast | RFC 3068 | C | 256 |
192.168.0.0 - 192.168.255.255 | 192.168.0.0/16 | Private IP addresses | RFC 1918 | C | 65,536 |
198.18.0.0 - 198.19.255.255 | 198.18.0.0/15 | Network Device Benchmark | RFC 2544 | C | 131,072 |
224.0.0.0 - 239.255.255.255 | 224.0.0.0/4 | Multicast | RFC 3171 | D | 268,435,456 |
240.0.0.0 - 255.255.255.255 | 240.0.0.0/4 | Reserved[3],[4],[5] | RFC 1166 | E | 268,435,456 |
[edit] See also
Friday, January 1, 2010
Subscribe to:
Posts (Atom)